Quartz 4

Home

❯

Learn everything at once

❯

Notes on using Defender, Sentinel, KQL and more

❯

Identifying vulnerable internet facing systems

Identifying vulnerable internet facing systems

Feb 18, 20261 min read

Links

https://www.kqlsearch.com/query/Cve-2024-3094-internet-facing-devices&cludstmqp01evmc0ptjq53m1k

KQL

DeviceTvmSoftwareVulnerabilities
| where CveId == "<CVE id>"
| join (DeviceInfo
| where IsInternetFacing == "1"
| project DeviceId, DeviceName, OSBuild, OSVersion, OSDistribution, OSVersionInfo
) on DeviceId
| distinct DeviceId, DeviceName, OSPlatform

Notes

none.


Graph View

  • Links
  • KQL
  • Notes

Recent Notes

  • Learn everything at once

    May 31, 2026

    • selfstudy
    • malware-development
    • malware-analysis
    • reverse-engineering
    • binary-analysis
    • algorithms
    • artificial-intelligence
    • ai
  • Malware development study notes

    May 28, 2026

    • Maldev-Academy-notes

      May 23, 2026

      • x64dbg
      • maldevacademy
      • socc
      • studie
      • pages
      • ProcessEnvironmentBlock
      • TlsSlots
      • TlsExpansionSlots
      • reserved
      • WinDbg
      • Encryption
      • runtime-analysis
      • heuristic-analysis
      • entropy

    Created with Quartz v4.5.2 © 2026

    • GitHub
    • Discord Community